[plt-dev] another scribble question

From: Chongkai Zhu (czhu at cs.utah.edu)
Date: Tue Jun 23 09:08:30 EDT 2009

Matthew Flatt wrote:
> At Tue, 23 Jun 2009 12:05:26 +0800, Chongkai Zhu wrote:
>> 1. After just installing the .plt file, the document is build but not 
>> listed under "Interoperability" of the main-index.
> For me, it's listed immediately after I install either through
> `setup-plt' or DrScheme. Can you send the install log, which may
> provide more hints?


> Also, are you working with a fresh user directory, so that opening
> documentation initially takes you to the installation-specific (but not
> user specific) help page, while opening documentation afterward takes
> you to the user-specific page? Or do you start out with at least a
> user-specific page, which is supposed to get updated?

I always mean 
I never use "file:///C:/Program%20Files/PLT-". 
Maybe I should update to latest SVN?

>> 2. By installing the .plt file, the html file is correctly rendered. I 
>> also want to generate a local html file that links to 
>> http://doc.plt-scheme.org/. So I execute
>> C:\Program Files\PLT->scribble.exe --html --redirect-main 
>> http://doc.plt-scheme.org/index.html docu.scrbl
>> I get an docu.html file (also attached), but obviously the links are not 
>> correct. I also tried "scribble.exe --html docu.scrbl" and got the same 
>> result. What did I do wrong here?
> Add
>   ++xref-in setup/xref load-collections-xref
> to the `scribble' command line, so that it loads in the cross
> references that will be redirected.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: log.txt
URL: <http://lists.racket-lang.org/dev/archive/attachments/20090623/bf173efe/attachment.txt>

Posted on the dev mailing list.