[plt-dev] Re: mred won't start on Ubuntu 9.10

From: Sam TH (samth at ccs.neu.edu)
Date: Tue Dec 1 12:24:16 EST 2009

This turns out to be a bug in some interaction between the ATI video
driver for my video card, the X server, and MrEd.  It's possible that
there's that MrEd is doing wrong here, but I'm not sure.  If anyone
wanted to investigate further, the correct place to look might start


On Tue, Dec 1, 2009 at 11:56 AM, Sam TH <samth at ccs.neu.edu> wrote:
> I just upgraded my laptop to ubuntu 9.10, and MrEd (and DrScheme, and
> Slideshow) now fails to start.  I get this error:
> mred: ../../src/xcb_io.c:542: _XRead: Assertion `dpy->xcb->reply_data
> != ((void *)0)' failed
> Aborted
> I have two other Ubuntu 9.10 desktop machines, and everything works
> fine for me there.
> Needless to say, this is pretty problematic for me.
> --
> sam th
> samth at ccs.neu.edu

sam th
samth at ccs.neu.edu

Posted on the dev mailing list.